unix sysadmin archives
Donation will make us pay more time on the project:
          

Monday 8 July 2013

How to support AIX (part1)

Before problems occur:
• Effective problem determination starts with a good understanding of the system and its components.
• The more information you have about the normal operation of a system, the better.
– System configuration
– Operating system level
– Applications installed
– Baseline performance
– Installation, configuration, and service manuals

A few good commands
• lspv Lists physical volumes, PVID, VG membership
• lscfg Provides information regarding system components
• prtconf Displays system configuration information
• lsvg Lists the volume groups
• lsps Displays information about paging spaces
• lsfs Gives file system information
• lsdev Provides device information
• getconf Displays values of system configuration variables
• bootinfo Displays system configuration information (unsupported)
• snap Collects system data

Steps in problem resolution
1.Identify the problem
2. Talk to users to define the problem
3. Collect system data
4. Resolve the problem

Progress and reference codes
• Progress codes
– Checkpoint during a process such as boot, shutdown, or dump
• System reference codes (SRCs)
– Error codes for problems in hardware, firmware, or operating system
• Service request numbers (SRNs)
– Indicates the detecting component and error condition detected
• Obtained from:
– Front panel of system enclosure
– HMC or IVM (for logically partitioned systems)
– Operator console message or diagnostics (diag utility)

Reference codes at IBM Information Center
http://pic.dhe.ibm.com/infocenter/powersys/v3r1m5/index.jsp


Working with AIX support
• Have needed information ready:
– Name, phone #, customer #,
– Machine type model and serial #,
– AIX version, release, technology level, and service pack
– Problem description, including error codes
– Severity level: critical, significant impact, some impact, minimal
• 1-800-IBM-SERV (1-800-426-7378)
• Level 1 will collect information and assign PMR number
• Route to level 2 responsible for the product
• You may be asked to collect additional information to upload
• They may ask you to update to a specific TL or SP
– APAR for your problem already addressed
– Need to have a standard environment for them to investigate

AIX support test case data
Run the following (or very similar) commands to gather snap information:
# snap –a comment: Copy any extra data to the /tmp/ibmsupt/testcase or the /tmp/ibmsupt/other directory
# snap –c comment: This step will create /tmp/ibmsupt/snap.pax.Z.
# cd /tmp/ibmsupt
# mv snap.pax.Z \
PMR#.b<branch#>.c<country#>.snap.pax.Z

Upload the information you have captured:
# ftp testcase.software.ibm.com
User: anonymous
Password: <your email address>
ftp> cd /toibm/aix
ftp> bin
ftp> put PMR#.b<branch#>.c<country#>.snap.pax.Z
ftp> quit

AIX software update hierarchy
• Version and release (oslevel)
– Requires new license and migration install
• Fileset updates (lslpp –L will show mod and fix levels)
– Collected changes to files in a fileset
– Related to APARs and PTFs
– Only need to apply the new fileset
• Fix bundles
– Collections of fileset updates
• Technology level and maintenance level (oslevel –r)
– Fix bundle of enhancements and fixes
• Service packs (oslevel –s)
– Fix bundle of important fixes
• Interim fixes
– Special situation code replacements
– Delay for normal PTF packaging is too slow
– Managed with efix tool

Thursday 4 July 2013

ufsrestore -if

Another helpful unix utility is the ufsrestore.
It's very handy, specially when you only have to restore a file or a specific directory.
This is preferable than netbackup for it's easiness.
But of course a ufsdump is needed for you to make use of this tool.

Here are the highlights of how to use it. Let say we want to restore /etc
#ufsrestore -ifv
add /etc
extract
Specify next volume #: 1 comment: in most cases is volume 1
set owner/mode for '.'? [yn] n comment: NO when restoring in directory other then one from which files were dumped
comment: YES if restoring in same directory from were dump was performed.

ufsrestore > quit